summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 02:36:06 -0400
committerMark H Weaver <mhw@netris.org>2018-04-12 04:02:13 -0400
commit8fcdd9d53ffdbc77d6bd3af416e2a3c41615e43b (patch)
tree391b12ee4a97a3f47e12fba7faa1afa45617a316 /gnu
parent831016bd22924e998b5135543451cd8b02b44560 (diff)
downloadguix-8fcdd9d53ffdbc77d6bd3af416e2a3c41615e43b.tar.gz
gnu: p7zip: Use invoke.
* gnu/packages/compression.scm (p7zip)[arguments]: Use invoke and remove
vestigial plumbing.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 32393a4c0a..7bc7d61c74 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1420,22 +1420,22 @@ It can be used as a replacement for the Apache @code{CBZip2InputStream} /
        (modify-phases %standard-phases
          (replace 'configure
            (lambda* (#:key system outputs #:allow-other-keys)
-             (zero? (system* "cp"
-                             (let ((system ,(or (%current-target-system)
-                                                (%current-system))))
-                               (cond
-                                ((string-prefix? "x86_64" system)
-                                 "makefile.linux_amd64_asm")
-                                ((string-prefix? "i686" system)
-                                 "makefile.linux_x86_asm_gcc_4.X")
-                                (else
-                                 "makefile.linux_any_cpu_gcc_4.X")))
-                             "makefile.machine"))))
+             (invoke "cp"
+                     (let ((system ,(or (%current-target-system)
+                                        (%current-system))))
+                       (cond
+                        ((string-prefix? "x86_64" system)
+                         "makefile.linux_amd64_asm")
+                        ((string-prefix? "i686" system)
+                         "makefile.linux_x86_asm_gcc_4.X")
+                        (else
+                         "makefile.linux_any_cpu_gcc_4.X")))
+                     "makefile.machine")))
          (replace 'check
            (lambda _
-             (and (zero? (system* "make" "test"))
-                  (zero? (system* "make" "test_7z"))
-                  (zero? (system* "make" "test_7zr"))))))))
+             (invoke "make" "test")
+             (invoke "make" "test_7z")
+             (invoke "make" "test_7zr"))))))
     (inputs
      (let ((system (or (%current-target-system)
                        (%current-system))))