summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2019-01-03 21:56:26 +0530
committerArun Isaac <arunisaac@systemreboot.net>2019-01-05 23:49:59 +0530
commitb18b9d204217c5e90afae0a7a71e82a21748f8e1 (patch)
treed6a7ebae1e7afdf54ed4a219c7e4bb7a239fa79a /gnu
parent0dd8da0b1d1cb613ed265734adfeff7cd3ebb190 (diff)
downloadguix-b18b9d204217c5e90afae0a7a71e82a21748f8e1.tar.gz
gnu: octave: Fix makeinfo path configuration.
* gnu/packages/maths.scm (octave-cli)[arguments]: Fix makeinfo path
configuration in configure-makeinfo phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 448d9e373b..e67bc5e935 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -19,7 +19,7 @@
 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
 ;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
 ;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
-;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2019 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Dave Love <me@fx@gnu.org>
 ;;; Copyright © 2018 Jan Nieuwenhuizen <janneke@gnu.org>
@@ -1484,11 +1484,10 @@ can solve two kinds of problems:
        (modify-phases %standard-phases
          (add-after 'configure 'configure-makeinfo
            (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "libinterp/corefcn/help.cc"
-               (("Vmakeinfo_program = \"makeinfo\"")
-                (string-append "Vmakeinfo_program = \""
-                               (assoc-ref inputs "texinfo")
-                               "/bin/makeinfo\"")))
+             (substitute* "libinterp/corefcn/help.h"
+               (("\"makeinfo\"")
+                (string-append
+                 "\"" (assoc-ref inputs "texinfo") "/bin/makeinfo\"")))
              #t)))))
     (home-page "https://www.gnu.org/software/octave/")
     (synopsis "High-level language for numerical computation")