summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-06-22 20:55:19 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-06-23 09:51:14 +0200
commitc29bb909d241e7215e574e93d9799e701cbc6ddb (patch)
tree7209a24fc2abd5a853ba40d1724c3bdac30f2d48 /gnu
parent42a2ee1f9294614bd85892f2cc7318afb80b174c (diff)
downloadguix-c29bb909d241e7215e574e93d9799e701cbc6ddb.tar.gz
gnu: fakeroot: Do not assume "sed" and "cut" to be available.
* gnu/packages/linux.scm (fakeroot)[inputs]: Add "sed" and "coreutils",
[arguments]: substitute "sed" and "cut" by their absolute path in fakeroot
script. Rename the associated phase from patch-getopt to patch-script.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ccb3e79041..1c34c5a2e1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6840,12 +6840,18 @@ the superuser to make device nodes.")
             (substitute* "Makefile"
              (("/bin/sh") (which "sh")))
             #t))
-        (add-after 'unpack 'patch-getopt
+        (add-after 'unpack 'patch-script
           (lambda*  (#:key inputs #:allow-other-keys)
             (substitute* "scripts/fakeroot.in"
              (("getopt")
               (string-append (assoc-ref inputs "util-linux")
-                             "/bin/getopt")))
+                             "/bin/getopt"))
+             (("sed")
+              (string-append (assoc-ref inputs "sed")
+                             "/bin/sed"))
+             (("cut")
+              (string-append (assoc-ref inputs "coreutils")
+                             "/bin/cut")) )
             #t))
         (add-before 'configure 'setenv
           (lambda _
@@ -6882,7 +6888,9 @@ the superuser to make device nodes.")
        ("xz" ,xz))) ; for the tests
     (inputs
      `(("libcap" ,libcap/next)
-       ("util-linux" ,util-linux)))
+       ("util-linux" ,util-linux)
+       ("sed" ,sed)
+       ("coreutils" ,coreutils)))
     (synopsis "Provides a fake root environment")
     (description "@command{fakeroot} runs a command in an environment where
 it appears to have root privileges for file manipulation. This is useful