summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-11 00:11:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-11 00:37:13 +0200
commitd037bf02947c273d780cdc1ee31710c27a30cf30 (patch)
treefd7399d237f2104a505b3a2e800b7b4a63203970 /gnu
parent1f34f8db12cdfb0fc12125e7e4cc490ea3cb5414 (diff)
downloadguix-d037bf02947c273d780cdc1ee31710c27a30cf30.tar.gz
gnu: squashfs-tools: Build from upstream git.
* gnu/packages/compression.scm (squashfs-tools)[source]: Use GIT-FETCH
and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm33
1 files changed, 17 insertions, 16 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 33d05173e9..d6aae89e50 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -856,22 +856,23 @@ time for compression ratio.")
   (package
     (name "squashfs-tools")
     (version "4.4")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://sourceforge/squashfs/squashfs/"
-                                  "squashfs" version "/"
-                                  "squashfs" version ".tar.gz"))
-              (sha256
-               (base32
-                "0zmhvczscqz0mzh4b9m8m42asq14db0a6lc8clp5ljq5ybrv70d9"))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  ;; Fix build with -fno-common (default in GCC 10).
-                  ;; Remove for squashfs-tools > 4.4.
-                  (substitute* "squashfs-tools/mksquashfs.h"
-                    (("struct cache \\*bwriter_buffer" all)
-                     (string-append "extern " all)))))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/plougher/squashfs-tools")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0697fv8n6739mcyn57jclzwwbbqwpvjdfkv1qh9s56lvyqnplwaw"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           ;; Fix build with -fno-common (default in GCC 10).
+           ;; Remove for squashfs-tools > 4.4.
+           (substitute* "squashfs-tools/mksquashfs.h"
+             (("struct cache \\*bwriter_buffer" all)
+              (string-append "extern " all)))))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no check target