summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-24 10:23:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-24 10:23:51 +0300
commiteb4cfec2762b7553fc4e26208e854140a8442c2e (patch)
treec6e54ef4e6a9991851552a209bb5928831f0f9b7 /gnu
parent2c9cb2f0a125289151c851e4806cc38da76dff3a (diff)
downloadguix-eb4cfec2762b7553fc4e26208e854140a8442c2e.tar.gz
gnu: ddate: Don't use unstable tarball.
* gnu/packages/linux.scm (ddate)[source]: Download using git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1c34c5a2e1..3b53114a75 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1486,12 +1486,13 @@ block devices, UUIDs, TTYs, and many other tools.")
     (name "ddate")
     (version "0.2.2")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/bo0ts/ddate/archive/v"
-                                  version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/bo0ts/ddate")
+                     (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
-               (base32 "1bbqqq8mswj4bp9083gxjaky5ysfznax4cynsqwmy125z053yg6m"))))
+               (base32 "1qchxnxvghbma6gp1g78wnjxsri0b72ha9axyk31cplssl7yn73f"))))
     (build-system cmake-build-system)
     (arguments '(#:tests? #f))
     (home-page "https://github.com/bo0ts/ddate")