summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-27 22:47:44 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-28 04:16:35 +0100
commitf43a7838716b80e439d1d94c00da6880d6f2893f (patch)
tree1b67f0360a01436ef0fba3091d897d051293d347 /gnu
parent511a8f8d468ad64ec8e117c827573f58552fdceb (diff)
downloadguix-f43a7838716b80e439d1d94c00da6880d6f2893f.tar.gz
gnu: clustershell: Update to 1.8.4.
* gnu/packages/ssh.scm (clustershell): Update to 1.8.4.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ssh.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index c8a1dbbe47..a681945f8e 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -824,7 +824,7 @@ framework.")
 (define-public clustershell
   (package
     (name "clustershell")
-    (version "1.8.3")
+    (version "1.8.4")
     (source
      (origin
        (method git-fetch)
@@ -833,7 +833,7 @@ framework.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "128v3gc6gj9622sp41az1jkcqnkbsdzvb2jpk12fpm1mmjcfgfvc"))))
+        (base32 "11b87vyamcw4rvgxz74jxwkr9ly0h9ldp2wqsi5wc19p0r06la5j"))))
     (build-system python-build-system)
     (inputs `(("openssh" ,openssh)))
     (propagated-inputs `(("python-pyyaml" ,python-pyyaml)))
@@ -845,8 +845,7 @@ framework.")
                         (substitute* "lib/ClusterShell/Worker/Ssh.py"
                           (("info\\(\"ssh_path\"\\) or \"ssh\"")
                            (string-append "info(\"ssh_path\") or \""
-                                          ssh "/bin/ssh\"")))
-                        #t))))))
+                                          ssh "/bin/ssh\"")))))))))
     (home-page "https://cea-hpc.github.io/clustershell/")
     (synopsis "Scalable event-driven Python framework for cluster administration")
     (description