summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-02-23 16:11:30 +0100
committerJakub Kądziołka <kuba@kadziolka.net>2020-02-23 17:58:38 +0100
commitf6b4d395fd321d43fd548ba832c78320ac3f8d51 (patch)
treeb0f8dea6f8d3c96b44e9cfeb76a6563a23412e82 /gnu
parent4fed945280ce32f87d804d171f827c81ffd64a2a (diff)
downloadguix-f6b4d395fd321d43fd548ba832c78320ac3f8d51.tar.gz
gnu: z3: Build the Python bindings
* gnu/packages/maths.scm (z3)[arguments]: Add the --python and
  --pypkgdir flags to configure. To facilitate the latter, add
  (guix build python-build-system) to #:modules and #:imported-modules.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 535ba02ea6..cab84a520b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -33,6 +33,7 @@
 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
 ;;; Copyright © 2019 Robert Smith <robertsmith@posteo.net>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4181,7 +4182,12 @@ as equations, scalars, vectors, and matrices.")
                 "0hprcdwhhyjigmhhk6514m71bnmvqci9r8gglrqilgx424r6ff7q"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
+     `(#:imported-modules ((guix build python-build-system)
+                           ,@%gnu-build-system-modules)
+       #:modules (((guix build python-build-system) #:select (site-packages))
+                  (guix build gnu-build-system)
+                  (guix build utils))
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-compatability
            ;; Versions after 4.8.3 have immintrin.h IFDEFed for Windows only.
@@ -4198,7 +4204,9 @@ as equations, scalars, vectors, and matrices.")
          (replace 'configure
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (invoke "./configure"
-                     (string-append "--prefix=" (assoc-ref outputs "out")))))
+                     "--python"
+                     (string-append "--prefix=" (assoc-ref outputs "out"))
+                     (string-append "--pypkgdir=" (site-packages inputs outputs)))))
          (add-after 'configure 'change-directory
            (lambda _
              (chdir "build")