summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 15:40:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 15:41:44 +0300
commitfaec049c3be41e2ea4a767fde16bf378e2b00780 (patch)
tree5e003bac22a892837f4730223522fb9da93c8a66 /gnu
parent6fe7d216b22b2408806cb851e17ec1083e5068ba (diff)
downloadguix-faec049c3be41e2ea4a767fde16bf378e2b00780.tar.gz
gnu: postorius: Update to 1.3.3.
* gnu/packages/mail.scm (postorius): Update to 1.3.3.
[arguments]: Build with python-3. Add custom 'check phase.
[inputs]: Replace python2-django, python2-django-mailman3,
python2-django-mailmanclient with python- variants. Add
python-readme-renderer.
[native-inputs]: Add python-beautifulsoup4, python-isort, python-mock,
python-vcrpy.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm34
1 files changed, 22 insertions, 12 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 3022f5c22f..87e8e3f770 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2791,26 +2791,36 @@ some configuration.")
 (define-public postorius
   (package
     (name "postorius")
-    (version "1.0.3")
+    (version "1.3.3")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "postorius" version "+post2.tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (uri (pypi-uri "postorius" version))
        (sha256
         (base32
-         "1wymcpv2icjjy8h1ni52p6dr7wwxf71ivqgbqhzx4i82yqphcaq5"))))
+         "08jn23gblbkfl09qlykbpsmp39mmach3sl69h1j5cd5kkx839rwa"))))
     (build-system python-build-system)
     (arguments
-     `(; One test dependency relies on Persona, which was shut down in
-       ;; November 2016.
-       #:tests? #f
-       ;; The part of the frontend of Mailman is still python 2.7.
-       #:python ,python-2))
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (add-installed-pythonpath inputs outputs)
+             (if tests?
+                 (invoke "python" "example_project/manage.py" "test"
+                         "--settings=test_settings" "postorius")
+                 #t))))
+       #:tests? #f)) ; Tests try to run a mailman instance to test against.
     (inputs
-     `(("python2-django" ,python2-django)
-       ("python2-django-mailman3" ,python2-django-mailman3)
-       ("python2-mailmanclient" ,python2-mailmanclient)))
+     `(("python-django" ,python-django)
+       ("python-django-mailman3" ,python-django-mailman3)
+       ("python-mailmanclient" ,python-mailmanclient)
+       ("python-readme-renderer" ,python-readme-renderer)))
+    (native-inputs
+     `(("python-beautifulsoup4" ,python-beautifulsoup4)
+       ("python-isort" ,python-isort)
+       ("python-mock" ,python-mock)
+       ("python-vcrpy" ,python-vcrpy)))
     (home-page "https://gitlab.com/mailman/postorius")
     (synopsis "Web user interface for GNU Mailman")
     (description