summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-15 10:16:49 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-02-15 10:17:46 +0200
commitff0c847687ce796d61c94ca07ffa6d646339d095 (patch)
tree62c816357006228aad6f4418c8123147f3a72e42 /gnu
parent5cd2c1e8c1dc3b0a18c2c6d4f2432b81e3a55f75 (diff)
downloadguix-ff0c847687ce796d61c94ca07ffa6d646339d095.tar.gz
gnu: ed: Use 'modify-phases'.
* gnu/packages/ed.scm (ed)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ed.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/ed.scm b/gnu/packages/ed.scm
index 953f739d31..3668aac19a 100644
--- a/gnu/packages/ed.scm
+++ b/gnu/packages/ed.scm
@@ -40,11 +40,12 @@
     (native-inputs `(("lzip" ,lzip)))
     (arguments
      '(#:configure-flags '("CC=gcc")
-       #:phases (alist-cons-before 'patch-source-shebangs 'patch-test-suite
-                                   (lambda _
-                                     (substitute* "testsuite/check.sh"
-                                       (("/bin/sh") (which "sh"))))
-                                   %standard-phases)))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'patch-source-shebangs 'patch-test-suite
+                     (lambda _
+                       (substitute* "testsuite/check.sh"
+                         (("/bin/sh") (which "sh"))))))))
     (home-page "http://www.gnu.org/software/ed/")
     (synopsis "Line-oriented text editor")
     (description