summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 12:59:06 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:22 -0500
commit03b0c92e2a75c73204791fa28858e0de21856c14 (patch)
tree4d6d3f88b96a509e7eb86e62ac264a288a43b7be /gnu
parent1a825512d35864186de38c7494188691d10c8c01 (diff)
downloadguix-03b0c92e2a75c73204791fa28858e0de21856c14.tar.gz
gnu: ghc-megaparsec: Update to 7.0.5.
* gnu/packages/haskell-xyz.scm (ghc-megaparsec): Update to 7.0.5.
[arguments]: Remove '#:cabal-revision'.
(ghc-megaparsec-7): Remove variable.
* gnu/packages/haskell-apps.scm (kmonad)[inputs]: Replace
'ghc-megaparsec-7' with 'ghc-megaparsec'.
* gnu/packages/idris.scm (idris)[inputs]: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-apps.scm2
-rw-r--r--gnu/packages/haskell-xyz.scm25
-rw-r--r--gnu/packages/idris.scm2
3 files changed, 4 insertions, 25 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index eac07ca9b8..1e0dafe227 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -543,7 +543,7 @@ and mIRC chat codes.")
        ("ghc-exceptions" ,ghc-exceptions)
        ("ghc-hashable" ,ghc-hashable)
        ("ghc-lens" ,ghc-lens)
-       ("ghc-megaparsec" ,ghc-megaparsec-7)
+       ("ghc-megaparsec" ,ghc-megaparsec)
        ("ghc-optparse-applicative" ,ghc-optparse-applicative)
        ("ghc-unagi-chan" ,ghc-unagi-chan)
        ("ghc-unliftio" ,ghc-unliftio)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 9ebde51ee2..cfc5f05c35 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6120,7 +6120,7 @@ functions are often useful in statistical and numerical computing.")
 (define-public ghc-megaparsec
   (package
     (name "ghc-megaparsec")
-    (version "6.5.0")
+    (version "7.0.5")
     (source
      (origin
        (method url-fetch)
@@ -6129,11 +6129,8 @@ functions are often useful in statistical and numerical computing.")
                            version ".tar.gz"))
        (sha256
         (base32
-         "12iggy7qpf8x93jm64zf0g215xwy779bqyfyjk2bhmxqqr1yzgdy"))))
+         "0bqx1icbmk8s7wmbcdzsgnlh607c7kzg8l80cp02dxr5valjxp7j"))))
     (build-system haskell-build-system)
-    (arguments
-     `(#:cabal-revision
-       ("4" "0ij3asi5vwlhbgwsy6nhli9a0qb7926mg809fsgyl1rnhs9fvpx1")))
     (inputs
      `(("ghc-case-insensitive" ,ghc-case-insensitive)
        ("ghc-parser-combinators" ,ghc-parser-combinators)
@@ -6151,24 +6148,6 @@ Megaparsec is a feature-rich package that strikes a nice balance between
 speed, flexibility, and quality of parse errors.")
     (license license:bsd-2)))
 
-;;; Idris 1.3.2 requires 'megaparse>=7.0.4' but we'd like to keep the public
-;;; package at the current Stackage LTS version:
-(define-public ghc-megaparsec-7
-  (hidden-package
-   (package
-     (inherit ghc-megaparsec)
-     (version "7.0.5")
-     (source
-      (origin
-        (method url-fetch)
-        (uri (string-append "https://hackage.haskell.org/package/megaparsec/"
-                            "megaparsec-" version ".tar.gz"))
-        (sha256
-         (base32
-          "0bqx1icbmk8s7wmbcdzsgnlh607c7kzg8l80cp02dxr5valjxp7j"))))
-     (arguments (strip-keyword-arguments (list #:cabal-revision)
-                                         (package-arguments ghc-megaparsec))))))
-
 (define-public ghc-memory
   (package
     (name "ghc-memory")
diff --git a/gnu/packages/idris.scm b/gnu/packages/idris.scm
index cd682832bc..e5c0ac210e 100644
--- a/gnu/packages/idris.scm
+++ b/gnu/packages/idris.scm
@@ -70,7 +70,7 @@
        ("ghc-fsnotify" ,ghc-fsnotify)
        ("ghc-ieee754" ,ghc-ieee754)
        ("ghc-libffi" ,ghc-libffi)
-       ("ghc-megaparsec" ,ghc-megaparsec-7)
+       ("ghc-megaparsec" ,ghc-megaparsec)
        ("ghc-network" ,ghc-network)
        ("ghc-optparse-applicative" ,ghc-optparse-applicative)
        ("ghc-regex-tdfa" ,ghc-regex-tdfa)