summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-14 21:26:11 +0200
committerMarius Bakke <marius@gnu.org>2020-07-14 21:29:13 +0200
commit07c1ccb1eb5ed5f7cb471530d06df3cd8713b135 (patch)
tree7bbb7f1a2a8af905da00c087fdca46930f44c0bd /gnu
parentf2c37028850fa03d6a25ae6c1d8366fe4b76374b (diff)
downloadguix-07c1ccb1eb5ed5f7cb471530d06df3cd8713b135.tar.gz
gnu: python-asn1crypto: Update to 1.3.0.
* gnu/packages/python-crypto.scm (python-asn1crypto): Update to 1.3.0.
[arguments]: New field.  Override check phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-crypto.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 5c9c251c01..fd3f918591 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -714,7 +714,7 @@ ECB and OFB).")
 (define-public python-asn1crypto
   (package
     (name "python-asn1crypto")
-    (version "0.24.0")
+    (version "1.3.0")
     (source
       (origin
        (method git-fetch)
@@ -724,8 +724,13 @@ ECB and OFB).")
         (file-name (git-file-name name version))
         (sha256
          (base32
-          "10lai2cs5mnz3gpaffbw1m7b885ls8328q5wxm35vfmcip1f0xmb"))))
+          "0c7rj3hs9fplrj4bv63ppvnnr8fay727w3a9zx3jfkz63wklvm1w"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      (invoke "python" "run.py" "tests"))))))
     (home-page "https://github.com/wbond/asn1crypto")
     (synopsis "ASN.1 parser and serializer in Python")
     (description "asn1crypto is an ASN.1 parser and serializer with definitions