summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-05-24 22:17:09 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-28 11:36:03 +0200
commit0ab7796f4d8989619c8091a5e3c36507161b6743 (patch)
tree9f56c89792ae60002d3aa36f6e54ebd1e8fd9744 /gnu
parent45a96b3f03e1876e4172d4408cdb53fa904bd274 (diff)
downloadguix-0ab7796f4d8989619c8091a5e3c36507161b6743.tar.gz
gnu: tryton: Use local 'inputs' instead of global '%build-inputs'.
The former is preferred above the latter.

* gnu/packages/tryton.scm (tryton-phases): Look up "trytond" in the
  'inputs' argument instead of in '%build-inputs'.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 800e19d827..107d5b4a7c 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -150,13 +150,13 @@ and security.")
 If present, pass EXTRA-ARGUMENTS to runtest as well."
   `(modify-phases %standard-phases
      (replace 'check
-       (let ((runtest
-              (string-append
-               (assoc-ref %build-inputs "trytond")
-               "/lib/python"
-               ,(version-major+minor (package-version python))
-               "/site-packages/trytond/tests/run-tests.py")))
-         (lambda* (#:key inputs outputs #:allow-other-keys)
+       (lambda* (#:key inputs outputs #:allow-other-keys)
+         (let ((runtest
+                (string-append
+                 (assoc-ref inputs "trytond")
+                 "/lib/python"
+                 ,(version-major+minor (package-version python))
+                 "/site-packages/trytond/tests/run-tests.py")))
            (add-installed-pythonpath inputs outputs)
            (invoke "python" runtest "-m" ,module ,@extra-arguments))))))