summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:09:46 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:52 -0400
commit1a0dbf0ded3991e655fdd223234409bbc8454792 (patch)
treefb98a065087d9dd42fce562d48d4486a65012459 /gnu
parent7c14128dd006a744bd5f3f4413206664a1538f45 (diff)
downloadguix-1a0dbf0ded3991e655fdd223234409bbc8454792.tar.gz
gnu: Add ghc-haskeline.
* gnu/packages/haskell.scm (ghc-haskeline): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 161b247a00..342babf8f2 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6536,4 +6536,31 @@ that hides the C implementation.")
      "This module provides set and multiset operations on ordered lists.")
     (license license:bsd-3)))
 
+(define-public ghc-haskeline
+  (package
+    (name "ghc-haskeline")
+    (version "0.7.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/haskeline/haskeline-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "09wd6sxgn65xxpk7dhy1cg3ywlbk0ccqq7xylycwk4zazy3gjgkd"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ncurses" ,ncurses)))
+    (arguments
+     `(#:configure-flags (list "-fterminfo")))
+    (home-page "https://github.com/judah/haskeline")
+    (synopsis "Command-line interface for user input")
+    (description
+     "Haskeline provides a user interface for line input in command-line
+programs.  This library is similar in purpose to readline, but since it
+is written in Haskell it is (hopefully) more easily used in other Haskell
+programs.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here