summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:03:58 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:13 +0300
commit21a3de583debe1bca86bdaf537d1f97bf2ffb53f (patch)
treefe1ea405d8a3151506d2ec3d14ea531a7e980960 /gnu
parent2c63f724862984883825bd7be13dff02b25f6e48 (diff)
downloadguix-21a3de583debe1bca86bdaf537d1f97bf2ffb53f.tar.gz
gnu: Add emacs-org-ref.
* gnu/packages/emacs.scm (emacs-org-ref): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ca10da740e..714e7a390e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9120,3 +9120,43 @@ throw a shell history.")
     (description "This package provides allows to discover key bindings and
 their meaning for the current Emacs major-mode.")
     (license license:gpl3+)))
+
+(define-public emacs-org-ref
+  (let ((commit "8c9b5d7efb9f0c1ad5186b8203bdd017f4249129")
+        (revision "1"))
+    (package
+      (name "emacs-org-ref")
+      (version (string-append "1.1.1" "-" revision "."
+                              (string-take commit 7)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/jkitchin/org-ref.git")
+               (commit commit)))
+         (file-name (string-append name "-" version "-checkout"))
+         (sha256
+          (base32
+           "1rxz0bjdsayk0slv23i07d9xhj2m7s4hsc81wc2d1cs52dkr5zmz"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-dash" ,emacs-dash)
+         ("emacs-helm" ,emacs-helm)
+         ("emacs-helm-bibtex" ,emacs-helm-bibtex)
+         ("emacs-ivy" ,emacs-ivy)
+         ("emacs-hydra" ,emacs-hydra)
+         ("emacs-key-chord" ,emacs-key-chord)
+         ("emacs-s" ,emacs-s)
+         ("emacs-f" ,emacs-f)
+         ("emacs-pdf-tools" ,emacs-pdf-tools)))
+      (home-page "https://github.com/jkitchin/org-ref")
+      (synopsis "Citations, cross-references and bibliographies in org-mode")
+      (description
+       "Lisp code to setup bibliography, cite, ref and label org-mode links.
+Also sets up reftex and helm for org-mode citations.  The links are
+clickable and do things that are useful.
+
+The default setup uses helm-bibtex.
+
+You should really read org-ref.org in this package for details.")
+      (license license:gpl3+))))