summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-04 14:20:52 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-04 16:29:14 +0200
commit3166e7324eb67ed9c43da97ee33ce35b24d6d342 (patch)
treebe879ed5584efb221cb22bf8739936f73cfc3f2b /gnu
parentc098af67b1ccc58ad55f64262c964111f046f923 (diff)
downloadguix-3166e7324eb67ed9c43da97ee33ce35b24d6d342.tar.gz
gnu: Add ghc-finite-typelits.
* gnu/packages/haskell-xyz.scm (ghc-finite-typelits): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e6fe09c282..7ed0db6c66 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4575,6 +4575,26 @@ described in section 4 of Ralf Hinze and Ross Paterson, \"Finger trees: a
 simple general-purpose data structure\".")
     (license license:bsd-3)))
 
+(define-public ghc-finite-typelits
+  (package
+    (name "ghc-finite-typelits")
+    (version "0.1.4.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "finite-typelits/"
+                           "finite-typelits-" version ".tar.gz"))
+       (sha256
+        (base32 "0iyp9fyd2ki9qcmk9infz9p6rjhsx9jrs3f5yz0yqs8vj5na81yj"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/mniip/finite-typelits")
+    (synopsis "Finitely many values, indexed by type-level naturals")
+    (description
+     "This package provides a Haskell type inhabited by finitely many values
+and indexed by type-level naturals.")
+    (license license:bsd-3)))
+
 (define-public ghc-fixed
   (package
     (name "ghc-fixed")