summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-01-02 20:04:53 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-01-05 10:29:51 +0100
commit42d6bffc2ff55406e75bf2f7096d4074c18cf382 (patch)
tree4a7ef24a9b1c14430de4ae8299250b8d47d27ad2 /gnu
parent007c75f56fc48b031c1383c98b6bbb3c1e3c30ad (diff)
downloadguix-42d6bffc2ff55406e75bf2f7096d4074c18cf382.tar.gz
gnu: Add python2-mmtk.
* gnu/packages/python.scm (python2-mmtk): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3dde9af340..d64c9bf850 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12249,3 +12249,44 @@ physical units, automatic derivatives, ...) whereas others are more
 domain-specific (e.g. netCDF and PDB support).  The library is currently
 not actively maintained and works only with Python 2 and NumPy < 1.9.")
     (license license:cecill-c)))
+
+(define-public python2-mmtk
+  (package
+    (name "python2-mmtk")
+    (version "2.7.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://bitbucket.org/khinsen/"
+                           "mmtk/downloads/MMTK-" version ".tar.gz"))
+       (file-name (string-append "MMTK-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1k4gsd50zja89dbzgy3aji7h4zpvbvdfrds7rxr3whqrsgcffnir"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("netcdf" ,netcdf)))
+    (propagated-inputs
+     `(("python-scientific" ,python2-scientific)
+       ("python-tkinter" ,python-2 "tk")))
+    (arguments
+     `(#:python ,python-2
+       #:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'includes-from-scientific
+           (lambda* (#:key inputs #:allow-other-keys)
+             (mkdir-p "Include/Scientific")
+             (copy-recursively
+                     (string-append
+                      (assoc-ref inputs "python-scientific")
+                      "/include/python2.7/Scientific")
+                     "Include/Scientific"))))))
+    (home-page "http://dirac.cnrs-orleans.fr/MMTK")
+    (synopsis "Python library for molecular simulation")
+    (description "MMTK is a library for molecular simulations with an emphasis
+on biomolecules.  It provides widely used methods such as Molecular Dynamics
+and normal mode analysis, but also basic routines for implementing new methods
+for simulation and analysis.  The library is currently not actively maintained
+and works only with Python 2 and NumPy < 1.9.")
+    (license license:cecill-c)))