summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-14 19:37:46 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-14 19:37:46 +0100
commit5254f17eebeef1690617ea0c17fc454ca91242bc (patch)
tree45b4baafeb02b0a0a989ab1509badeb866c92f9e /gnu
parent5f07df1743b159da6310b46074a031a294106dcb (diff)
downloadguix-5254f17eebeef1690617ea0c17fc454ca91242bc.tar.gz
gnu: at-spi2-core: Update to 2.32.0.
* gnu/packages/gtk.scm (at-spi2-core): Update to 2.32.0.
[arguments]: Adjust for renamed configure flag.
[inputs]: Move LIBXI and LIBXTST ...
[propagated-inputs]: ... here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a18dd005eb..b62a4aaa27 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -555,7 +555,7 @@ in the GNOME project.")
 (define-public at-spi2-core
   (package
    (name "at-spi2-core")
-   (version "2.28.0")
+   (version "2.32.0")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnome/sources/" name "/"
@@ -563,12 +563,12 @@ in the GNOME project.")
                                 name "-" version ".tar.xz"))
             (sha256
              (base32
-              "11qwdxxx4jm0zj04xydlwah41axiz276dckkiql3rr0wn5x4i8j2"))))
+              "083j1v7kdjrpjsv1b9dl3d8xqj39jyp4cfn8i9gbbm7q2g93b923"))))
    (build-system meson-build-system)
    (outputs '("out" "doc"))
    (arguments
     '(#:configure-flags
-      (list "-Denable_docs=true")
+      (list "-Ddocs=true")
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'set-documentation-path
@@ -605,9 +605,8 @@ in the GNOME project.")
    (propagated-inputs
     ;; atspi-2.pc refers to all these.
     `(("dbus" ,dbus)
-      ("glib" ,glib)))
-   (inputs
-    `(("libxi" ,libxi)
+      ("glib" ,glib)
+      ("libxi" ,libxi)
       ("libxtst" ,libxtst)))
    (native-inputs
     `(("gobject-introspection" ,gobject-introspection)