summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-06 23:30:00 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:50 -0500
commit55069500a291a42278286bf7509ef6423601110a (patch)
tree7448921a4296eb935fef6e2a0e8605b1263c15b6 /gnu
parent59f423214e2cff50ca7cdecebc70dc783286d3cc (diff)
downloadguix-55069500a291a42278286bf7509ef6423601110a.tar.gz
gnu: Add Module-Util.
* gnu/packages/perl.scm (perl-module-util): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 432a11af76..db45532603 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2764,6 +2764,29 @@ from Moose::Conflicts and moose-outdated.")
 programs for dependencies.")
     (license (package-license perl))))
 
+(define-public perl-module-util
+  (package
+    (name "perl-module-util")
+    (version "1.09")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/M/MA/MATTLAW/"
+                           "Module-Util-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1ip2yg3x517gg8c48crhd52ba864vmyimvm0ibn4ci068mmcpyvc"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-module-build" ,perl-module-build))) ; >= 0.40
+    (home-page "http://search.cpan.org/dist/Module-Util")
+    (synopsis "Module name tools and transformations")
+    (description "This module provides a few useful functions for manipulating
+module names.  Its main aim is to centralise some of the functions commonly
+used by modules that manipulate other modules in some way, like converting
+module names to relative paths.")
+    (license (package-license perl))))
+
 (define-public perl-moo
   (package
     (name "perl-moo")