summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 19:24:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:40 +0100
commit73f055df34b1d174544e0232b5aaf1d735f90d9e (patch)
tree02813178852febc621cb6e733141d866278d00a4 /gnu
parentfa82997feac8636464bcf92571236105e1719999 (diff)
downloadguix-73f055df34b1d174544e0232b5aaf1d735f90d9e.tar.gz
gnu: Add r-acmeeqtl.
* gnu/packages/cran.scm (r-acmeeqtl): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ddbd8dec25..943a1b629f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17186,3 +17186,28 @@ as with usual R matrices.  It supports very large matrices; the package has
 been tested on multi-terabyte matrices.  It allows for more than 2^32 rows or
 columns, ad allows for quick addition of extra columns to a filematrix.")
     (license license:lgpl3)))
+
+(define-public r-acmeeqtl
+  (package
+    (name "r-acmeeqtl")
+    (version "1.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ACMEeqtl" version))
+       (sha256
+        (base32
+         "049xjv2ym35bbn43zwi68cq27fwdh404vp0r2ca5gxgmmx8kj1cz"))))
+    (properties `((upstream-name . "ACMEeqtl")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-filematrix" ,r-filematrix)))
+    (home-page "https://github.com/andreyshabalin/ACMEeqtl")
+    (synopsis "Estimation of interpretable eQTL effect sizes")
+    (description
+     "This package provides a non-linear model, termed ACME, that reflects a
+parsimonious biological model for allelic contributions of cis-acting eQTLs.
+With non-linear least-squares algorithm the maximum likelihood parameters can
+be estimated.  The ACME model provides interpretable effect size estimates and
+p-values with well controlled Type-I error.")
+    (license license:lgpl3)))