summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-05-08 11:48:01 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-08 11:48:01 +0200
commita605ef3ce9dbd6b79dd9322f89d9facaf875b487 (patch)
treecabb9aa74f3f0e0dd35386cd9800fa688264576c /gnu
parent7b7bc91c3d7fba306884cd1681d12b51246c2aea (diff)
downloadguix-a605ef3ce9dbd6b79dd9322f89d9facaf875b487.tar.gz
gnu: libgc@8: Build with '--disable-munmap'.
Partially fixes <https://bugs.gnu.org/40525>.

* gnu/packages/bdw-gc.scm (libgc)[arguments]: Configure with
'--disable-munmap'.
* gnu/packages/guile.scm (guile-3.0/libgc-7): Remove.
* gnu/packages/ci.scm (cuirass)[inputs]: Refer to GUILE-3.0-LATEST
instead of GUILE-3.0/LIBGC-7.
* guix/self.scm (specification->package): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bdw-gc.scm8
-rw-r--r--gnu/packages/ci.scm2
-rw-r--r--gnu/packages/guile.scm11
3 files changed, 7 insertions, 14 deletions
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index 50e4951dc1..0d82889bac 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2016, 2017, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2016, 2017, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
@@ -46,7 +46,11 @@
       (list
        ;; Install gc_cpp.h et al.
        "--enable-cplusplus"
-       ;; In GNU/Hurd systems during the 'Check' phase,
+
+       ;; Work around <https://github.com/ivmai/bdwgc/issues/353>.
+       "--disable-munmap"
+
+       ;; In GNU/Hurd systems during the 'check' phase,
        ;; there is a deadlock caused by the 'gctest' test.
        ;; To disable the error set "--disable-gcj-support"
        ;; to configure script. See bug report and discussion:
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index 8d93513332..f03fbfdd98 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -150,7 +150,7 @@
                    `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,objs)))
                  #t))))))
       (inputs
-       `(("guile" ,guile-3.0/libgc-7)
+       `(("guile" ,guile-3.0-latest)
          ("guile-avahi" ,guile-avahi)
          ("guile-fibers" ,guile-fibers)
          ("guile-gcrypt" ,guile-gcrypt)
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index fdda6cd733..5bef56a891 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -319,17 +319,6 @@ without requiring the source code to be rewritten.")
   ;; The latest 3.0.x version.
   guile-3.0)
 
-(define-public guile-3.0/libgc-7
-  ;; Using libgc-7 avoid crashes that can occur, particularly when loading
-  ;; data in to the Guix Data Service:
-  ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=40525
-  (hidden-package
-   (package
-     (inherit guile-3.0-latest)
-     (propagated-inputs
-      `(("bdw-gc" ,libgc-7)
-        ,@(srfi-1:alist-delete "bdw-gc" (package-propagated-inputs guile-3.0)))))))
-
 (define-public guile-3.0/fixed
   ;; A package of Guile that's rarely changed.  It is the one used in the
   ;; `base' module, and thus changing it entails a full rebuild.