summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:22 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:14 -0700
commitc1274a0b7930bc799710f681a8a0d19d3d7e2ac1 (patch)
tree711e49cd53e96b52b0307792707742bafd0612f7 /gnu
parent78d8b8f36ac8ffd859424b13d7e714eb2d38282a (diff)
downloadguix-c1274a0b7930bc799710f681a8a0d19d3d7e2ac1.tar.gz
gnu: Add ghc-vector-th-unbox.
* gnu/packages/haskell.scm (ghc-vector-th-unbox): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4d8fa2125f..be6b0893f5 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9032,4 +9032,28 @@ which allow you to avoid direct usage of conduits.")
 directly uses the type system, rather than out-of-band exceptions.")
     (license license:bsd-3)))
 
+(define-public ghc-vector-th-unbox
+  (package
+    (name "ghc-vector-th-unbox")
+    (version "0.2.1.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "vector-th-unbox-" version "/"
+                           "vector-th-unbox-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0d82x55f5vvr1jvaia382m23rs690lg55pvavv8f4ph0y6kd91xy"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-vector" ,ghc-vector)
+       ("ghc-data-default" ,ghc-data-default)))
+    (home-page "https://github.com/liyang/vector-th-unbox")
+    (synopsis "Deriver for Data.Vector.Unboxed using Template Haskell")
+    (description "This Haskell library provides a Template Haskell
+deriver for unboxed vectors, given a pair of coercion functions to
+and from some existing type with an Unbox instance.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here