summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-02-17 15:29:26 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-02-17 16:16:36 +0200
commitcc128eefd7ec77c84c5d8a5cab4db03823d13112 (patch)
tree52b7d75a77794767eebdbc2f8cf7a7b8445b4b22 /gnu
parent16c0cc5cfe7283a0170662b1880dd640d99f8a4d (diff)
downloadguix-cc128eefd7ec77c84c5d8a5cab4db03823d13112.tar.gz
gnu: ruby-rubocop-performance: Update to 1.9.2.
* gnu/packages/ruby.scm (ruby-rubocop-performance): Update to 1.9.2.
[source]: Download from git uri.
[arguments]: Replace 'replace-git-ls-files phase. Add 'set-home phase.
[propagated-inputs]: Add ruby-rubocop-ast.
[native-inputs]: Add ruby-bump, ruby-yard.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm31
1 files changed, 25 insertions, 6 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d1fe82b2ee..1934a68c01 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1549,19 +1549,38 @@ logic.")
 (define-public ruby-rubocop-performance
   (package
     (name "ruby-rubocop-performance")
-    (version "1.7.1")
+    (version "1.9.2")
     (source
      (origin
-       (method url-fetch)
-       (uri (rubygems-uri "rubocop-performance" version))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/rubocop-hq/rubocop-performance")
+              (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "04r8d4x62ygv17spvz9yyfxbmbf8qxwhijs0xycfvzr0q4pyg9sw"))))
+         "04lmkmz6c0ccs5miikrww7lakp7y6xz00g7b47ay7rn7sx5j6qyf"))))
     (build-system ruby-build-system)
     (arguments
-     `(#:tests? #f))                    ;no test suite in the distributed gem
+     `(#:tests? #f  ; tests require a git checkout of rubocop's source code.
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'replace-git-ls-files
+           (lambda _
+             (substitute* "rubocop-performance.gemspec"
+               (("`git ls-files -z config lib LICENSE.txt README.md`")
+                "`find config lib LICENSE.txt README.md -type f -print0 |sort -z`"))
+             #t))
+         (add-before 'check 'set-HOME
+           (lambda _
+             (setenv "HOME" "/tmp")
+             #t)))))
     (propagated-inputs
-     `(("ruby-rubocop" ,ruby-rubocop)))
+     `(("ruby-rubocop" ,ruby-rubocop)
+       ("ruby-rubocop-ast" ,ruby-rubocop-ast)))
+    (native-inputs
+     `(("ruby-bump" ,ruby-bump)
+       ("ruby-yard" ,ruby-yard)))
     (synopsis "Performance optimizations checkers for Ruby code")
     (description "This package provides a collection of RuboCop cops to check
 for performance optimizations in Ruby code.")