summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 18:55:57 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:08 +0300
commitd7403c126c5682bb61c7c014c7380ed138722d2e (patch)
tree07b1afa1b8cd5b9514901248a98346684da45aaa /gnu
parentf8a88f223ea2ac36576cd92f457790df5a6f2408 (diff)
downloadguix-d7403c126c5682bb61c7c014c7380ed138722d2e.tar.gz
gnu: Add emacs-rainbow-blocks.
* gnu/packages/emacs.scm (emacs-rainbow-blocks): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 8dd3e9dbff..c3badab852 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8382,3 +8382,26 @@ functions or modules in a larger multi-file Emacs package and
 facilitate running from the source tree without having to install the
 code or fiddle with evil @code{load-path}.")
       (license license:gpl3+))))
+
+(define-public emacs-rainbow-blocks
+  (let ((commit "dd435d7bb34ff6f162a5f315df308b90b7e9f842"))
+    (package
+      (name "emacs-rainbow-blocks")
+      (version (git-version "1.0.0" "1" commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/istib/rainbow-blocks.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "06yfb3i7wzvqrhkb61zib9xvpb5i00s4frizkzff66im05k0n795"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/istib/rainbow-blocks")
+      (synopsis "Highlight sexp blocks")
+      (description "Rainbow-blocks is an Emacs mode that highlights blocks
+made of parentheses, brackets, and braces according to their depth.  Each
+successive level is highlighted in a different color.  This makes it easy to
+orient yourself in the code, and tell which statements are at a given level.")
+      (license license:gpl3+))))