summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:07:46 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:15 +0300
commitf4dc59a28e9f5734986231052cdf4ed62461b41c (patch)
treed94b63ff2e8033ecb8a6da2e8d32ad8874045a44 /gnu
parent26165a796012d619feba1beb20fff5487e7e701a (diff)
downloadguix-f4dc59a28e9f5734986231052cdf4ed62461b41c.tar.gz
gnu: Add emacs-f3.
* gnu/packages/emacs.scm (emacs-f3): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 609bc87faa..1b5a3e6d7b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9467,3 +9467,25 @@ If you have a @file{todo.org} file with @code{TODO} items in the root of your
 repository, @code{magit-org-todos} will create a section in your Magit status
 buffer with each of your todos.")
       (license license:gpl3+))))
+
+(define-public emacs-f3
+  (package
+    (name "emacs-f3")
+    (version "0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/cosmicexplorer/f3/archive/"
+                           version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "06b8i1jvklm5k3k90n65f197l1miq1xlxqkqpbppw4h3rhl4y98h"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-helm" ,emacs-helm)))
+    (home-page "https://github.com/cosmicexplorer/f3")
+    (synopsis "Fantastic File Finder for Emacs")
+    (description
+     "The Fantastic File Finder for Emacs.  Find files fast, using helm.")
+    (license license:gpl3+)))