summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 18:55:05 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:08 +0300
commitfb3aeaf7de9182d5300464e54f58181da6b37110 (patch)
tree0ebe0973be467643961924f9b1121f4489774bcd /gnu
parent53d4090b0eb0f4ecbfc147ac1dbad3ec3c85d76c (diff)
downloadguix-fb3aeaf7de9182d5300464e54f58181da6b37110.tar.gz
gnu: Add emacs-move-text.
* gnu/packages/emacs.scm (emacs-move-text): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f217001de6..ed5d19497c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8316,3 +8316,24 @@ arXiv, Google Scholar, Library of Congress, etc.
     (synopsis "List-manipulation utility functions")
     (description "This package provides a list manipulation library for Emacs.")
     (license license:gpl3+)))
+
+(define-public emacs-move-text
+  (package
+    (name "emacs-move-text")
+    (version "2.0.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/emacsfodder/move-text/archive/"
+                           version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1sjfja9r25692pgcldgnjzkapzy970m14jh9l4pajysiqcdk72g0"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/emacsfodder/move-text")
+    (synopsis "Move current line or region with M-up or M-down")
+    (description "This package provide functions to move the current line
+using @kbd{M-up} or @kbd{M-down} if a region is marked, it will move the
+region instead.")
+    (license license:gpl3+)))