summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2019-10-15 22:12:32 -0500
committerBrian Leung <leungbk@mailfence.com>2019-10-18 07:15:15 +0200
commitfec41bceb8d98f74baa2392d45bb46102bad5ddf (patch)
tree5f3a733c2316debc818945dc3d1bdf1dfc41862a /gnu
parent919c5e1b43ca440fa0128f21f7d75780b6c238a4 (diff)
downloadguix-fec41bceb8d98f74baa2392d45bb46102bad5ddf.tar.gz
gnu: Add emacs-minibuffer-line.
* gnu/packages/emacs-xyz.scm (emacs-minibuffer-line): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4ced731edf..31899c1f86 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19430,3 +19430,29 @@ nondestructively, and computes the dimmed faces dynamically such that your
 overall color scheme is shown in a muted form without requiring you to define
 what is a \"dim\" version of every face.")
     (license license:gpl3+)))
+
+(define-public emacs-minibuffer-line
+  (package
+    (name "emacs-minibuffer-line")
+    (version "0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://elpa.gnu.org/packages/minibuffer-line-"
+             version
+             ".el"))
+       (sha256
+        (base32 "1ny4iirp26na5118wfgxlv6fxlrdclzdbd9m0lkrv51w0qw7spil"))))
+    (build-system emacs-build-system)
+    (home-page "https://elpa.gnu.org/packages/minibuffer-line.html")
+    (synopsis "Display status info in the minibuffer window")
+    (description
+     "This package lets you display various status information in the
+minibuffer window instead of the mode-line.  Of course, this is only displayed
+when the minibuffer window is not already used for other things (e.g. a
+minibuffer or an each area message).
+
+The contents and aspect is controlled by the @code{minibuffer-line-format}
+variable and the @code{minibuffer-line} face.")
+    (license license:gpl3+)))