summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:31:33 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:31:33 +0200
commitfbb162de75b7824b88935d52bc3bd7444925b784 (patch)
treed16c838638dc9fe1ef88df4f145db8e0e418521a /gnu
parent4a3df6c8e181962911423eaae1a2c5b9274edc1c (diff)
downloadguix-fbb162de75b7824b88935d52bc3bd7444925b784.tar.gz
gnu: emacs-better-defaults: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-better-defaults)[source]: Download
using git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2634b309e8..cdfb93061f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5937,13 +5937,14 @@ possible to query other endpoints like DBPedia.")
     (version "0.1.3")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/technomancy/better-defaults"
-                           "/archive/" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/technomancy/better-defaults")
+              (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "08fg4zslzlxbvyil5g4gwvwd22fh4zsgqprs5wh9hv1rgc6757m2"))))
+         "1rxznx2l0cdpiz8mad8s6q17m1fngpgb1cki7ch6yh18r3qz8ysr"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/technomancy/better-defaults")
     (synopsis "Better defaults for Emacs")