summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-01-02 17:45:37 +0000
committerLeo Famulari <leo@famulari.name>2022-01-02 13:16:51 -0500
commit01ec5efff7cf95cae69493bd4ccfdd21a38770ae (patch)
tree7b1b55a20420f3fc8c4acf38e07444dab1db593f /gnu
parentdfc5d5247f0e3d355c25484ea3d95ba2a6077895 (diff)
downloadguix-01ec5efff7cf95cae69493bd4ccfdd21a38770ae.tar.gz
gnu: gcompris: Fix build with GCC 10.
* gnu/packages/education.scm (gcompris)[arguments]: Add -fcommon to CFLAGS.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/education.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index efb2df474e..cf1236a90f 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -96,6 +96,8 @@
        ;; of Gstreamer.
        (list "--enable-sdlmixer"
              "LDFLAGS=-lgmodule-2.0")
+       #:make-flags
+       (list "CFLAGS=-fcommon")
        #:phases
        (modify-phases %standard-phases
          (add-after 'set-paths 'set-sdl-paths