summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-08-05 14:23:22 -0400
committerMark H Weaver <mhw@netris.org>2014-08-05 20:00:37 -0400
commit13c8c2bf1325ffc041b8105dc405efa324769a39 (patch)
treef78c4e2f3a8d170bf70039428a55200524a81bbf /gnu
parent42dc3af5bfc8458de0289d66cb069d0e2efbad39 (diff)
downloadguix-13c8c2bf1325ffc041b8105dc405efa324769a39.tar.gz
gnu: Add acpica.
* gnu/packages/admin.scm (acpica): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 8abc6677ac..ce8c9dc38b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -850,3 +850,36 @@ BIOS/EFI/coreboot/firmware/optionROM images on mainboards,
 network/graphics/storage controller cards, and various other
 programmer devices.")
     (license gpl2)))
+
+(define-public acpica
+  (package
+    (name "acpica")
+    (version "20140724")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://acpica.org/sites/acpica/files/acpica-unix2-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "01vdgrh7dsxrrvg5yd8sxm63cw8210pnsi5qg9g15ac53gn243ac"))))
+    (build-system gnu-build-system)
+    (native-inputs `(("flex" ,flex)
+                     ("bison" ,bison)))
+    (arguments
+     '(#:make-flags (list (string-append "PREFIX=" %output)
+                          "HOST=_LINUX"
+                          "OPT_CFLAGS=-Wall -fno-strict-aliasing")
+       #:tests? #f  ; no 'check' target.
+       #:phases (alist-delete 'configure %standard-phases)))
+    (home-page "http://acpica.org/")
+    (synopsis "ACPICA tools for the development and debug of ACPI tables")
+    (description
+     "The ACPI Component Architecture (ACPICA) project provides an
+OS-independent reference implementation of the Advanced Configuration and
+Power Interface Specification (ACPI).  ACPICA code contains those portions of
+ACPI meant to be directly integrated into the host OS as a kernel-resident
+subsystem, and a small set of tools to assist in developing and debugging ACPI
+tables.  This package contains only the user-space tools needed for ACPI table
+development, not the kernel implementation of ACPI.")
+    (license gpl2)))  ; Dual GPLv2/ACPICA Licence