summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-08-08 22:37:32 +0200
committerAndreas Enge <andreas@enge.fr>2014-08-08 22:37:32 +0200
commit35536412a42425a9c19e7f0f233a71886adb9233 (patch)
treeb6d5920fb7ecad2957612f1246283d645ad27d91 /gnu
parent43dd1cf360e911201d4d3bbfe5bb6fdbb418366e (diff)
downloadguix-35536412a42425a9c19e7f0f233a71886adb9233.tar.gz
gnu: xorg: Add presentproto.
* gnu/packages/xorg.scm (presentproto): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index d6edefc6fc..ce3c4ec2e1 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1544,6 +1544,28 @@ tracking.")
     (license license:x11)))
 
 
+;; not part of X11R7.7, required for newer versions of mesa
+(define-public presentproto
+  (package
+    (name "presentproto")
+    (version "1.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "mirror://xorg/individual/proto/presentproto-"
+               version
+               ".tar.bz2"))
+        (sha256
+          (base32
+            "1kir51aqg9cwazs14ivcldcn3mzadqgykc9cg87rm40zf947sb41"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.x.org/wiki/")
+    (synopsis "xorg implementation of the X Window System")
+    (description "X.org provides an implementation of the X Window System")
+    (license (license:x11-style "file://presentproto.h"
+                                "See 'presentproto.h' in the distribution."))))
+
 ;; The package is missing from X11R7.7.
 (define-public printproto
   (package