summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-29 12:27:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-29 12:28:44 +0200
commit3ad0ec5fa79a43c2050c3552e5c5a9eb4687625d (patch)
tree2c3ab2f90b5c705eca3351926525b53dbed7bb76 /gnu
parentae00ea94aa14097c61b15cbac016baeacdd1113a (diff)
downloadguix-3ad0ec5fa79a43c2050c3552e5c5a9eb4687625d.tar.gz
gnu: Add r-float.
* gnu/packages/cran.scm (r-float): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ed834985cf..a17f5d2281 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17837,6 +17837,33 @@ Python programming language whose design became a de facto standard in
 industry for machine learning tasks.")
     (license license:expat)))
 
+(define-public r-float
+  (package
+    (name "r-float")
+    (version "0.2-4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "float" version))
+       (sha256
+        (base32
+         "1wf1dfybgbhvh9sa5z41xkh8liwp5n9gyydfq2mpg6bag0r457z1"))))
+    (properties `((upstream-name . "float")))
+    (build-system r-build-system)
+    (native-inputs
+     `(("gfortran" ,gfortran)))
+    (home-page "https://github.com/wrathematics/float")
+    (synopsis "32-bit floats")
+    (description
+     "R comes with a suite of utilities for linear algebra with
+\"numeric\" (double precision) vectors/matrices.  However, sometimes single
+precision (or less!) is more than enough for a particular task.  This package
+extends R's linear algebra facilities to include 32-bit float (single
+precision) data.  Float vectors/matrices have half the precision of their
+\"numeric\"-type counterparts but are generally faster to numerically operate
+on, for a performance vs accuracy trade-off.")
+    (license license:bsd-2)))
+
 (define-public r-xmlparsedata
   (package
     (name "r-xmlparsedata")