summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-18 16:59:59 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-18 17:01:21 +0000
commit3b1cf6ab5ea1c1e47d02372148529595990176eb (patch)
tree448b05e0ae33733e5958f9a22335e85e2a1a8390 /gnu
parent9e76a5b7cb84534bcda7507773b681f13df11698 (diff)
downloadguix-3b1cf6ab5ea1c1e47d02372148529595990176eb.tar.gz
gnu: python-typer: Use GUIX_PYTHONPATH instead of PYTHONPATH.
* gnu/packages/python-xyz.scm (python-typer)[arguments]: Use GUIX_PYTHONPATH
in 'check phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e9ec5ff059..3115d367b2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20869,9 +20869,9 @@ based on the CPython 2.7 and 3.7 parsers.")
              ;; This is for completion tests
              (with-output-to-file "/tmp/.bashrc" (lambda _ (display "# dummy")))
 
-             (setenv "PYTHONPATH"
+             (setenv "GUIX_PYTHONPATH"
                      (string-append (getcwd) ":"
-                                    (getenv "PYTHONPATH")))
+                                    (getenv "GUIX_PYTHONPATH")))
              (let ((disabled-tests (list "test_show_completion"
                                          "test_install_completion")))
                (invoke "python" "-m" "pytest" "tests/"