summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-29 12:28:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-29 12:28:44 +0200
commit4aa90cb4b3cf79764ddbbbe7d6f2d05d887436fd (patch)
treed69aa2b6deaf0ea2f9dbe7f1a917d175bd28ea54 /gnu
parent05238ae30e361e0ed391b467a28c2c467050c4f0 (diff)
downloadguix-4aa90cb4b3cf79764ddbbbe7d6f2d05d887436fd.tar.gz
gnu: Add r-cistopic-next.
* gnu/packages/bioconductor.scm (r-cistopic-next): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 284a0e7f12..b6e2e74bfe 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -10249,6 +10249,46 @@ includes functionalities to identify cell states based on the contribution of
 cisTopics and explore the nature and regulatory proteins driving them.")
     (license license:gpl3)))
 
+(define-public r-cistopic-next
+  (let ((commit "04cecbb9d1112fcc1a6edc28b5a506bcb49f2803")
+        (revision "1"))
+    (package
+      (inherit r-cistopic)
+      (name "r-cistopic-next")
+      ;; The DESCRIPTION file says this is version 0.3.0, which is a bit odd
+      ;; since the previous release is 2.1.0.  Oh well.
+      (version (git-version "0.3.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/aertslab/cisTopic")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "11cg9szlysnsjiaahda4k5v2vh4rxx27zhz53hafgaq9mdz0kgi2"))))
+      (properties `((upstream-name . "cisTopic")))
+      (propagated-inputs
+       `(("r-aucell" ,r-aucell)
+         ("r-data-table" ,r-data-table)
+         ("r-dosnow" ,r-dosnow)
+         ("r-dplyr" ,r-dplyr)
+         ("r-dt" ,r-dt)
+         ("r-feather" ,r-feather)
+         ("r-fitdistrplus" ,r-fitdistrplus)
+         ("r-genomicranges" ,r-genomicranges)
+         ("r-ggplot2" ,r-ggplot2)
+         ("r-lda" ,r-lda)
+         ("r-matrix" ,r-matrix)
+         ("r-plyr" ,r-plyr)
+         ("r-rcistarget" ,r-rcistarget)
+         ("r-rtracklayer" ,r-rtracklayer)
+         ("r-s4vectors" ,r-s4vectors)
+         ("r-text2vec" ,r-text2vec)))
+      (native-inputs
+       `(("r-knitr" ,r-knitr))))))
+
 (define-public r-genie3
   (package
     (name "r-genie3")