summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-16 16:59:29 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-16 16:59:52 +0100
commit7dce1df34b5838f8d8915dab3127a27bbb8a430f (patch)
tree9348802eca2bbf54faac10d39348d2996793de04 /gnu
parent912cb917b87f0cb938bab2141a04c6fae3cc9b33 (diff)
downloadguix-7dce1df34b5838f8d8915dab3127a27bbb8a430f.tar.gz
gnu: Add texlive-xifthen.
* gnu/packages/tex.scm (texlive-xifthen): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ed171475ab..bfca91310a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8875,6 +8875,27 @@ on the page, and which specifies where it is to be placed.  The environment is
 accompanied by various configuration commands.")
     (license license:lppl)))
 
+(define-public texlive-xifthen
+  (package
+    (inherit (simple-texlive-package
+              "texlive-xifthen"
+              (list "doc/latex/xifthen/"
+                    "tex/latex/xifthen/")
+              (base32
+               "0b33mlmnxsj5mi06v2w2zgamk51mgv1lxdr1cax8nkpn9g7n9axw")
+              #:trivial? #t))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/xifthen")
+    (synopsis "Extended conditional commands")
+    (description
+     "This package extends the @code{ifthen} package by implementing new
+commands to go within the first argument of @code{\\\\ifthenelse}: to test
+whether a string is void or not, if a command is defined or equivalent to
+another.  The package also enables use of complex expressions as introduced by
+the package @code{calc}, together with the ability of defining new commands to
+handle complex tests.")
+    (license license:lppl)))
+
 (define-public bibtool
   (package
     (name "bibtool")