summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-19 20:45:09 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-20 08:57:02 -0500
commitcb09adc09305b342a902ee13d78abb2a7cee4cdd (patch)
tree7cce4f7d8a8672f95022dc3be0c7223cff89a4c5 /gnu
parentafacad8b67d624b2b0f206acb7233785a296be7c (diff)
downloadguix-cb09adc09305b342a902ee13d78abb2a7cee4cdd.tar.gz
gnu: wayland: Use native-inputs unconditionally
* gnu/packages/freedesktop.scm (wayland): Remove trailing #t.
[phases]: Use native-inputs unconditionally.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm22
1 files changed, 7 insertions, 15 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 1d8a4c0bbb..46bc0516c5 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -996,24 +996,17 @@ Python.")
         #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-docbook-xml
-           ;; TODO(core-updates): Use 'native-inputs' unconditionally
-           (lambda* (#:key ,@(if (%current-target-system)
-                                 '(native-inputs)
-                                 '())
-                     inputs #:allow-other-keys)
+           (lambda* (#:key native-inputs inputs #:allow-other-keys)
              (with-directory-excursion "doc"
                (substitute* (find-files "." "\\.xml$")
                  (("http://www.oasis-open.org/docbook/xml/4\\.5/")
-                  (string-append (assoc-ref ,(if (%current-target-system)
-                                                 '(or native-inputs inputs)
-                                                 'inputs) "docbook-xml")
+                  (string-append (assoc-ref (or native-inputs inputs)
+                                            "docbook-xml")
                                  "/xml/dtd/docbook/"))
                  (("http://www.oasis-open.org/docbook/xml/4\\.2/")
-                  (string-append (assoc-ref ,(if (%current-target-system)
-                                                 '(or native-inputs inputs)
-                                                 'inputs) "docbook-xml-4.2")
-                                 "/xml/dtd/docbook/"))))
-             #t))
+                  (string-append (assoc-ref (or native-inputs inputs)
+                                            "docbook-xml-4.2")
+                                 "/xml/dtd/docbook/"))))))
          (add-after 'install 'move-doc
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -1021,8 +1014,7 @@ Python.")
                (mkdir-p (string-append doc "/share"))
                (rename-file
                 (string-append out "/share/doc")
-                (string-append doc "/share/doc"))
-               #t))))))
+                (string-append doc "/share/doc"))))))))
     (native-inputs
      `(("docbook-xml-4.2" ,docbook-xml-4.2)
        ("docbook-xml" ,docbook-xml)