summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-01-06 01:36:00 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-01-31 23:37:13 -0500
commitd3e439e355284f136ff13eb3e6fffb4661552f3b (patch)
tree624e123167079a142ddacb1c3d7b00e73f7f3490 /gnu
parent76f5428bc6b4b4d944be1c16f50d6e558416635f (diff)
downloadguix-d3e439e355284f136ff13eb3e6fffb4661552f3b.tar.gz
gnu: Add earlyoom-service-type.
* gnu/services/linux.scm: New file.
* tests/services/linux.scm: Add test.
* Makefile.am (SCM_TESTS): Register test.
* doc/guix.texi (Linux Services): Add a new section and document the new
service and its configuration.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/services/linux.scm125
1 files changed, 125 insertions, 0 deletions
diff --git a/gnu/services/linux.scm b/gnu/services/linux.scm
new file mode 100644
index 0000000000..caa0326c31
--- /dev/null
+++ b/gnu/services/linux.scm
@@ -0,0 +1,125 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu services linux)
+  #:use-module (guix gexp)
+  #:use-module (guix records)
+  #:use-module (guix modules)
+  #:use-module (gnu services)
+  #:use-module (gnu services shepherd)
+  #:use-module (gnu packages linux)
+  #:use-module (srfi srfi-1)
+  #:use-module (srfi srfi-26)
+  #:use-module (ice-9 match)
+  #:export (earlyoom-configuration
+            earlyoom-configuration?
+            earlyoom-configuration-earlyoom
+            earlyoom-configuration-minimum-available-memory
+            earlyoom-configuration-minimum-free-swap
+            earlyoom-configuration-prefer-regexp
+            earlyoom-configuration-avoid-regexp
+            earlyoom-configuration-memory-report-interval
+            earlyoom-configuration-ignore-positive-oom-score-adj?
+            earlyoom-configuration-show-debug-messages?
+            earlyoom-configuration-send-notification-command
+            earlyoom-service-type))
+
+
+;;;
+;;; Early OOM daemon.
+;;;
+
+(define-record-type* <earlyoom-configuration>
+  earlyoom-configuration make-earlyoom-configuration
+  earlyoom-configuration?
+  (earlyoom earlyoom-configuration-earlyoom
+            (default earlyoom))
+  (minimum-available-memory earlyoom-configuration-minimum-available-memory
+                            (default 10)) ; in percent
+  (minimum-free-swap earlyoom-configuration-minimum-free-swap
+                     (default 10))      ; in percent
+  (prefer-regexp earlyoom-configuration-prefer-regexp ; <string>
+                 (default #f))
+  (avoid-regexp earlyoom-configuration-avoid-regexp  ; <string>
+                (default #f))
+  (memory-report-interval earlyoom-configuration-memory-report-interval
+                          (default 0)) ; in seconds; 0 means disabled
+  (ignore-positive-oom-score-adj?
+   earlyoom-configuration-ignore-positive-oom-score-adj? (default #f))
+  (run-with-higher-priority? earlyoom-configuration-run-with-higher-priority?
+                             (default #f))
+  (show-debug-messages? earlyoom-configuration-show-debug-messages?
+                        (default #f))
+  (send-notification-command
+   earlyoom-configuration-send-notification-command  ; <string>
+   (default #f)))
+
+(define (earlyoom-configuration->command-line-args config)
+  "Translate a <earlyoom-configuration> object to its command line arguments
+representation."
+  (match config
+    (($ <earlyoom-configuration> earlyoom minimum-available-memory
+                                 minimum-free-swap prefer-regexp avoid-regexp
+                                 memory-report-interval
+                                 ignore-positive-oom-score-adj?
+                                 run-with-higher-priority? show-debug-messages?
+                                 send-notification-command)
+     `(,(file-append earlyoom "/bin/earlyoom")
+       ,@(if minimum-available-memory
+             (list "-m" (format #f "~s" minimum-available-memory))
+             '())
+       ,@(if minimum-free-swap
+             (list "-s" (format #f "~s" minimum-free-swap))
+             '())
+       ,@(if prefer-regexp
+             (list "--prefer" prefer-regexp)
+             '())
+       ,@(if avoid-regexp
+             (list "--avoid" avoid-regexp)
+             '())
+       "-r" ,(format #f "~s" memory-report-interval)
+       ,@(if ignore-positive-oom-score-adj?
+             (list "-i")
+             '())
+       ,@(if run-with-higher-priority?
+             (list "-p")
+             '())
+       ,@(if show-debug-messages?
+             (list "-d")
+             '())
+       ,@(if send-notification-command
+             (list "-N" send-notification-command)
+             '())))))
+
+(define (earlyoom-shepherd-service config)
+  (shepherd-service
+   (documentation "Run the Early OOM daemon.")
+   (provision '(earlyoom))
+   (start #~(make-forkexec-constructor
+             '#$(earlyoom-configuration->command-line-args config)
+             #:log-file "/var/log/earlyoom.log"))
+   (stop #~(make-kill-destructor))))
+
+(define earlyoom-service-type
+  (service-type
+   (name 'earlyoom)
+   (default-value (earlyoom-configuration))
+   (extensions
+    (list (service-extension shepherd-root-service-type
+                             (compose list earlyoom-shepherd-service))))
+   (description "Run @command{earlyoom}, the Early OOM daemon.")))