summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-11-03 20:37:27 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-11-03 20:43:35 +0200
commite9f305a1c82abe17cc67f0b349fcf09e7a002090 (patch)
tree0dc31a9453849e6561e295d6d1146b2ac3e5ac78 /gnu
parent0e091b3e9378cee49314b50e89b71ef5eacae457 (diff)
downloadguix-e9f305a1c82abe17cc67f0b349fcf09e7a002090.tar.gz
gnu: sbcl-lift: Don't keep the bundled website.
* gnu/packages/lisp.scm (sbcl-lift)[source]: Remove bundled website.
[arguments]: Remove custom 'make-gzips-writable phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index c32380969f..9fb25a15a2 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -2382,19 +2382,17 @@ new fiends in addition to old friends like @command{aif} and
          (sha256
           (base32
            "127v5avpz1i4m0lkaxqrq8hrl69rdazqaxf6s8awf0nd7wj2g4dp"))
-         (file-name (git-file-name "lift" version))))
+         (file-name (git-file-name "lift" version))
+         (modules '((guix build utils)))
+         (snippet
+          ;; Don't keep the bundled website
+          `(begin
+             (delete-file-recursively "website")
+             #t))))
       (build-system asdf-build-system/sbcl)
       (arguments
        ;; The tests require a debugger, but we run with the debugger disabled.
-       '(#:tests? #f
-         #:phases
-         (modify-phases %standard-phases
-           ;; Do this to ensure the 'reset-gzip-timestamps phase works.
-           (add-after 'unpack 'make-gzips-writeable
-             (lambda _
-               (for-each (lambda (file)
-                           (chmod file #o755))
-                         (find-files "." "\\.gz$")))))))
+       '(#:tests? #f))
       (synopsis "LIsp Framework for Testing")
       (description
        "The LIsp Framework for Testing (LIFT) is a unit and system test tool for LISP.