summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-17 22:31:51 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-19 01:48:07 +0200
commit4782a06f45d515eebc4d1ee8e958def409a0ef9f (patch)
tree2d405b98b8b2d1d3bba9e16d70a6068f83ae3d38 /gnu
parentc105e5090397f3f634c0cd082b4866b5222cd5b4 (diff)
downloadguix-4782a06f45d515eebc4d1ee8e958def409a0ef9f.tar.gz
gnu: python-send2trash: Properly delay python2 variant.
* gnu/packages/python-xyz.scm (python2-send2trash)[properties]: Move from here ...
(python-send2trash)[properties]: ... to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4e0a67a1e8..51382184d2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13581,6 +13581,7 @@ and works only with Python 2 and NumPy < 1.9.")
     (synopsis "Send files to the user's @file{~/Trash} directory")
     (description "This package provides a Python library to send files to the
 user's @file{~/Trash} directory.")
+    (properties `((python2-variant . ,(delay python-send2trash))))
     (license license:bsd-3)))
 
 (define-public python2-send2trash
@@ -13594,8 +13595,7 @@ user's @file{~/Trash} directory.")
              (lambda _
                (setenv "PYTHONPATH"
                        (string-append (getcwd) ":" (getenv "PYTHONPATH")))
-               #t))))))
-    (properties `((python2-variant . ,(delay python-send2trash))))))
+               #t))))))))
 
 (define-public python-yapf
   (package