summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-07-23 11:46:15 +0200
committerFederico Beffa <beffa@fbengineering.ch>2015-08-01 12:37:13 +0200
commit6d992d078e1994265d921ef4e301b5722c6503c6 (patch)
treef5637fefe01bb28478a2f19b495fc0eb9210c30f /gnu
parent61b9ac53c34ac3ab6f2661e0de50ea0292407267 (diff)
downloadguix-6d992d078e1994265d921ef4e301b5722c6503c6.tar.gz
gnu: Add python-ptyprocess.
* gnu/packages/python.scm (python-ptyprocess, python2-ptyprocess): New
  variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index aa4080f23c..c97cf9df06 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4571,3 +4571,36 @@ Python.")
 
 (define-public python2-mistune
   (package-with-python2 python-mistune))
+
+(define-public python-ptyprocess
+  (package
+    (name "python-ptyprocess")
+    (version "0.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/p/ptyprocess/ptyprocess-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "0nggns5kikn32yyda2zrj1xdmh49pi3v0drggcdwljbv36r8zdyw"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-setuptools" ,python-setuptools)
+       ("python-nose" ,python-nose)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+                  (lambda _
+                    (zero? (system* "nosetests")))))))
+    (home-page "https://github.com/pexpect/ptyprocess")
+    (synopsis "Run a subprocess in a pseudo terminal")
+    (description
+     "This package provides a Python library used to launch a subprocess in a
+pseudo terminal (pty), and interact with both the process and its pty.")
+    (license isc)))
+
+(define-public python2-ptyprocess
+  (package-with-python2 python-ptyprocess))