summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Dvorsak <eric@dvorsak.fr>2015-07-25 21:39:50 +0200
committerAlex Kost <alezost@gmail.com>2015-07-31 10:59:32 +0300
commitf9da1d8afaf2af40993fad8e82e9fed141613ac5 (patch)
tree65cab3b8b2667f66178b2148c7c0cd12f5b859ba /gnu
parentfeb0d9c3401e12307e1d45dcdb069107d7337a66 (diff)
downloadguix-f9da1d8afaf2af40993fad8e82e9fed141613ac5.tar.gz
gnu: Add python-passlib.
* gnu/packages/python.scm (python-passlib, python2-passlib): New variables.

Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f3d0e030a4..2e2e1be89c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -298,6 +298,47 @@ pidof, tty, taskset, pmap.")
 (define-public python2-psutil
   (package-with-python2 python-psutil))
 
+(define-public python-passlib
+  (package
+    (name "python-passlib")
+    (version "1.6.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/p/passlib/passlib-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0b9rd161b3mmiwd7nx1v599yh9sp07mlfwac65sjy9qn1l0gd1z9"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-nose" ,python-nose)
+       ("python-setuptools" ,python-setuptools)))
+    (inputs
+     `(("python-py-bcrypt" ,python-py-bcrypt)))
+    (arguments
+     `(#:phases
+       (alist-cons-before
+        'check 'set-PYTHON_EGG_CACHE
+        ;; some tests require access to "$HOME/.cython"
+        (lambda* _ (setenv "PYTHON_EGG_CACHE" "/tmp"))
+         %standard-phases)))
+    (home-page "https://bitbucket.org/ecollins/passlib")
+    (synopsis
+     "Comprehensive password hashing framework")
+    (description
+     "Passlib is a password hashing library for Python 2 & 3, which provides
+cross-platform implementations of over 30 password hashing algorithms, as well
+as a framework for managing existing password hashes.  It's designed to be
+useful for a wide range of tasks, from verifying a hash found in /etc/shadow,
+to providing full-strength password hashing for multi-user application.")
+    (license bsd-3)))
+
+(define-public python2-passlib
+  (package-with-python2 python-passlib))
+
 (define-public python-py-bcrypt
   (package
     (name "python-py-bcrypt")