summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-08 18:57:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-12 14:45:54 +0100
commit031fdda47af642d4316e128f9ca0c3fe2cf8b4bb (patch)
treea9f1aad7591d5812805d7bb8d43fc98eacd4f33d /gnu
parentf44079bc2151979cde33704fec73f1da1726a2f5 (diff)
downloadguix-031fdda47af642d4316e128f9ca0c3fe2cf8b4bb.tar.gz
gnu: r-gseabase: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-gseabase): Move from here...
* gnu/packages/bioconductor.scm (r-gseabase): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm29
-rw-r--r--gnu/packages/bioinformatics.scm29
2 files changed, 29 insertions, 29 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 1c298d61cf..a89797adc8 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1630,6 +1630,35 @@ exploration of the results.")
 high-throughput sequencing experiments.")
     (license license:artistic2.0)))
 
+(define-public r-gseabase
+  (package
+    (name "r-gseabase")
+    (version "1.52.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "GSEABase" version))
+       (sha256
+        (base32
+         "0dawh1kjmf6921jm77j2s2phrq5237pjc4sdh8fkln89gf48zx6i"))))
+    (properties `((upstream-name . "GSEABase")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotate" ,r-annotate)
+       ("r-annotationdbi" ,r-annotationdbi)
+       ("r-biobase" ,r-biobase)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-graph" ,r-graph)
+       ("r-xml" ,r-xml)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://bioconductor.org/packages/GSEABase")
+    (synopsis "Gene set enrichment data structures and methods")
+    (description
+     "This package provides classes and methods to support @dfn{Gene Set
+Enrichment Analysis} (GSEA).")
+    (license license:artistic2.0)))
+
 (define-public r-hpar
   (package
     (name "r-hpar")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 788f780f8d..4daaacd0cc 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7387,35 +7387,6 @@ includes software to
 ")
       (license license:cc0))))
 
-(define-public r-gseabase
-  (package
-    (name "r-gseabase")
-    (version "1.52.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "GSEABase" version))
-       (sha256
-        (base32
-         "0dawh1kjmf6921jm77j2s2phrq5237pjc4sdh8fkln89gf48zx6i"))))
-    (properties `((upstream-name . "GSEABase")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-annotate" ,r-annotate)
-       ("r-annotationdbi" ,r-annotationdbi)
-       ("r-biobase" ,r-biobase)
-       ("r-biocgenerics" ,r-biocgenerics)
-       ("r-graph" ,r-graph)
-       ("r-xml" ,r-xml)))
-    (native-inputs
-     `(("r-knitr" ,r-knitr)))
-    (home-page "https://bioconductor.org/packages/GSEABase")
-    (synopsis "Gene set enrichment data structures and methods")
-    (description
-     "This package provides classes and methods to support @dfn{Gene Set
-Enrichment Analysis} (GSEA).")
-    (license license:artistic2.0)))
-
 (define-public r-category
   (package
     (name "r-category")