summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2023-03-21 10:44:10 -0500
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-22 14:00:58 +0100
commit72644ce13f96b109a88cf067cc6e75beba3e9dae (patch)
tree60c264b75cfce9368dc28e66cf823ace04f91894 /gnu
parentbd84b284baccda72c7723fe35f24a105cfcb28e3 (diff)
downloadguix-72644ce13f96b109a88cf067cc6e75beba3e9dae.tar.gz
gnu: Add cl-music-spelling.
* gnu/packages/lisp-xyz.scm (cl-music-spelling, ecl-music-spelling,
  sbcl-music-spelling): New variables.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index f0efed478e..df435f10c1 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -27544,6 +27544,35 @@ roman numeral given in the key.")
           `(modify-phases ,phases
              (delete 'build-binary))))))))
 
+(define-public sbcl-music-spelling
+  (let ((commit "a2d492af440ad30a21042140cf8ffce4b73fbd42")
+        (revision "0"))
+    (package
+      (name "sbcl-music-spelling")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/ntrocado/music-spelling")
+               (commit commit)))
+         (file-name (git-file-name "cl-music-spelling" version))
+         (sha256
+          (base32 "0fgahb0jjr4sp2739d55gylmx8alsghnx3spyaqfqci4cxfrys52"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs (list sbcl-alexandria))
+      (home-page "https://github.com/ntrocado/music-spelling/")
+      (synopsis "Automatically spell musical pitches and rhythms")
+      (description "This package implements an algorithm for the spelling
+of enharmonics and dealing with ties and dots in rhythm notation.")
+      (license license:asl2.0))))
+
+(define-public cl-music-spelling
+  (sbcl-package->cl-source-package sbcl-music-spelling))
+
+(define-public ecl-music-spelling
+  (sbcl-package->ecl-package sbcl-music-spelling))
+
 (define-public sbcl-closure-template
   ;; There are no releases since 2015.
   (let ((commit "f1983aa525045691e128027d2a2d74831c873d6e")