summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorStephen Paul Weber <singpolyma@singpolyma.net>2021-09-24 21:44:39 -0500
committerLudovic Courtès <ludo@gnu.org>2021-10-13 11:48:03 +0200
commit987b50f4e9f7f6eccce9af82309c2d406a8cbe76 (patch)
tree2a363f1d1906b0752f8bfdc180186dd633f17022 /gnu
parent32e444da301de1a34fbce363a242f1fe0934ed22 (diff)
downloadguix-987b50f4e9f7f6eccce9af82309c2d406a8cbe76.tar.gz
gnu: Add runitor
* gnu/packages/admin.scm (runitor): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 850372bdc6..a00976eb33 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4794,3 +4794,31 @@ setup, maintenance, supervision, or any long-running processes.")
       (description "Utility to convert @code{lsof} output to a graph showing
 FIFO and UNIX interprocess communication.")
       (license license:bsd-2))))
+
+(define-public runitor
+  (package
+    (name "runitor")
+    (version "0.8.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/bdd/runitor")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "0vjfbyrbp5ywgzdz9j3x0qgjvnq7nw7193x8v9yy6k2cih1zsacn"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:unpack-path "bdd.fi/x/runitor"
+       #:go ,go-1.17
+       #:build-flags '(,(string-append "-ldflags=-X main.Version=" version))
+       #:import-path "bdd.fi/x/runitor/cmd/runitor"
+       #:install-source? #f))
+    (home-page "https://github.com/bdd/runitor")
+    (synopsis "Command runner with healthchecks.io integration")
+    (description
+      "Runitor runs the supplied command, captures its output, and based on its
+exit code reports successful or failed execution to
+@url{https://healthchecks.io,https://healthchecks.io} or your private instance.")
+    (license license:bsd-0)))