summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 17:15:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:28 +0200
commit06b17a52b79e6c3955b7ef1524aa4399eb33c9c9 (patch)
treef247f094fadd9a5790d76cdb73e1b2c052db7bbb /gnu
parent9272f0576adc7b2508e6cfb12c5b370853dcc2ee (diff)
downloadguix-06b17a52b79e6c3955b7ef1524aa4399eb33c9c9.tar.gz
gnu: texlive-xcharter: Refresh package definition.
* gnu/packages/tex.scm (texlive-xcharter): Remove SIMPLE-TEXLIVE-PACKAGE
call.
[propagated-inputs]: Add TEXLIVE-CARLISLE, TEXLIVE-ETOOLBOX, TEXLIVE-FONTAXES,
TEXLIVE-XSTRING, TEXLIVE-XKEYVAL.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm41
1 files changed, 25 insertions, 16 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5c7e9bd976..9dad5030bd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11306,22 +11306,31 @@ mathematics package that matches Libertine text quite well.")
 
 (define-public texlive-xcharter
   (package
-    (inherit (simple-texlive-package
-              "texlive-xcharter"
-              (list "/doc/fonts/xcharter/"
-                    "/fonts/afm/public/xcharter/"
-                    "/fonts/enc/dvips/xcharter/"
-                    "/fonts/map/dvips/xcharter/"
-                    "/fonts/opentype/public/xcharter/"
-                    "/fonts/tfm/public/xcharter/"
-                    "/fonts/type1/public/xcharter/"
-                    "/fonts/vf/public/xcharter/"
-                    "/tex/latex/xcharter/")
-              (base32
-               "0d8rvcmvxrlxqqxpirxqbhmiijpsz5y4vvldh1jnc018aannjlhm")
-              #:trivial? #t))
-    (home-page "https://www.ctan.org/pkg/xcharter")
-    (synopsis "Extension of the Bitstream Charter fonts")
+    (name "texlive-xcharter")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/xcharter/"
+                   "fonts/afm/public/xcharter/"
+                   "fonts/enc/dvips/xcharter/"
+                   "fonts/map/dvips/xcharter/"
+                   "fonts/opentype/public/xcharter/"
+                   "fonts/tfm/public/xcharter/"
+                   "fonts/type1/public/xcharter/"
+                   "fonts/vf/public/xcharter/"
+                   "tex/latex/xcharter/")
+             (base32
+              "0d8rvcmvxrlxqqxpirxqbhmiijpsz5y4vvldh1jnc018aannjlhm")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-carlisle
+           texlive-etoolbox
+           texlive-fontaxes
+           texlive-xstring
+           texlive-xkeyval))
+    (home-page "https://ctan.org/pkg/xcharter")
+    (synopsis "Extension of Bitstream Charter fonts")
     (description "@code{xcharter} repackages Bitstream Charter with an
 extended set of features.  The extension provides small caps, oldstyle
 figures and superior figures in all four styles, accompanied by LaTeX