summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 18:33:20 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:34:00 +0100
commit1365ae47d1668f0c2c7d619bc1d454a204269f0e (patch)
tree5d12100bec531b4a12891cbe91bd6aca63c94225 /gnu
parent79967eeafc17e40594220cc3113959ac4b9deb37 (diff)
downloadguix-1365ae47d1668f0c2c7d619bc1d454a204269f0e.tar.gz
gnu: Add ocaml-ppx-let.
* gnu/packages/ocaml.scm (ocaml-ppx-let): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6a56c712d5..6fbe762b6c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5669,3 +5669,27 @@ else expression.")
 used to handle optional compilations of pieces of code depending of the word
 size, the version of the compiler, ...")
     (license license:asl2.0)))
+
+(define-public ocaml-ppx-let
+  (package
+    (name "ocaml-ppx-let")
+    (version "0.11.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+                                  (version-major+minor version)
+                                  "/files/ppx_let-v" version ".tar.gz"))
+              (sha256
+               (base32
+                "1wdfw6w4xbg97a35yg6bif9gggxniy9ddnrjfw1a0inkl2yamxkj"))))
+    (build-system dune-build-system)
+    (propagated-inputs
+      `(("ocaml-base" ,ocaml-base)
+        ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+        ("ocaml-ppxlib" ,ocaml-ppxlib)))
+    (properties `((upstream-name . "ppx_let")))
+    (home-page "https://github.com/janestreet/ppx_let")
+    (synopsis "Monadic let-bindings")
+    (description "A ppx rewriter for monadic and applicative let bindings,
+match expressions, and if expressions.")
+    (license license:asl2.0)))