summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-29 10:53:45 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-29 10:58:25 -0500
commit23a5dcce1d893b8f5c5301ae3c1af863776ed3cf (patch)
treebb7e6c8d106961fdcb632c27abea54de3b754249 /gnu
parentde8dc9039b532f938074eb8504c63d3755d92eb6 (diff)
downloadguix-23a5dcce1d893b8f5c5301ae3c1af863776ed3cf.tar.gz
gnu: grocsvs: Remove package.
This package depends on Python 2 and doesn't build anymore.  Upstream doesn't
seem active, but if they ever port it to Python 3, they should let people know
here: https://github.com/grocsvs/grocsvs/issues/6.

* gnu/packages/bioinformatics.scm (grocsvs): Delete.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm41
1 files changed, 0 insertions, 41 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 161767c671..5b14e765de 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15607,44 +15607,3 @@ biological processes.  SBML is useful for models of metabolism, cell
 signaling, and more.  It continues to be evolved and expanded by an
 international community.")
     (license license:lgpl2.1+)))
-
-(define-public grocsvs
-  ;; The last release is out of date and new features have been added.
-  (let ((commit "ecd956a65093a0b2c41849050e4512d46fecea5d")
-        (revision "1"))
-    (package
-      (name "grocsvs")
-      (version (git-version "0.2.6.1" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                       (url "https://github.com/grocsvs/grocsvs")
-                       (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32 "14505725gr7qxc17cxxf0k6lzcwmgi64pija4mwf29aw70qn35cc"))
-                (patches (search-patches "grocsvs-dont-use-admiral.patch"))))
-      (build-system python-build-system)
-      (arguments
-       `(#:tests? #f            ; No test suite.
-         #:python ,python-2))   ; Only python-2 supported.
-      (inputs
-       `(("python2-h5py" ,python2-h5py)
-         ("python2-ipython-cluster-helper" ,python2-ipython-cluster-helper)
-         ("python2-networkx" ,python2-networkx)
-         ("python2-psutil" ,python2-psutil)
-         ("python2-pandas" ,python2-pandas)
-         ("python2-pybedtools" ,python2-pybedtools)
-         ("python2-pyfaidx" ,python2-pyfaidx)
-         ("python2-pygraphviz" ,python2-pygraphviz)
-         ("python2-pysam" ,python2-pysam)
-         ("python2-scipy" ,python2-scipy)))
-      (home-page "https://github.com/grocsvs/grocsvs")
-      (synopsis "Genome-wide reconstruction of complex structural variants")
-      (description
-       "@dfn{Genome-wide Reconstruction of Complex Structural Variants}
-(GROC-SVs) is a software pipeline for identifying large-scale structural
-variants, performing sequence assembly at the breakpoints, and reconstructing
-the complex structural variants using the long-fragment information from the
-10x Genomics platform.")
-       (license license:expat))))