summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-08-23 17:41:15 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-23 17:41:15 +0200
commit25adb1b6cdf00b3ec78b6fe9e47af97b0dc42180 (patch)
tree95709b0d8ef22acab226115aa3beba71f0eb5997 /gnu
parent721bf4c0018274b9ea53993ed88b6496be24060d (diff)
downloadguix-25adb1b6cdf00b3ec78b6fe9e47af97b0dc42180.tar.gz
gnu: python2-gamera: Disable wxpython support.
The package doesn't build when wxpython support is activated, and the only
dependent (didjvu) doesn't need it.

* gnu/packages/python-xyz.scm (python2-gamera)[inputs]: Remove
  python2-wxpython.
  [arguments]: Add 'disable-wx-support' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f499a40ca4..994001d72f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25276,10 +25276,16 @@ process.")
     (inputs
      `(("libpng" ,libpng)
        ("libtiff" ,libtiff)
-       ("python2-wxpython" ,python2-wxpython)
        ("zlib" ,zlib)))
     (arguments
-     `(#:python ,python-2))
+     `(#:python ,python-2
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'disable-wx-support
+           (lambda _
+             (substitute* "setup.py"
+               (("no_wx = False")
+                "no_wx = True")))))))
     (synopsis "Framework for building document analysis applications")
     (description
      "Gamera is a toolkit for building document image recognition systems.")