summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 21:58:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:10 +0200
commit267ffd0a045da071578e802313dfe7121958cf91 (patch)
tree56f4981363637929ce616ed7cf9c019849045661 /gnu
parenta84395f2d34187e23b1e04dd558a460053f884db (diff)
downloadguix-267ffd0a045da071578e802313dfe7121958cf91.tar.gz
gnu: texlive-cs: Refresh package definition.
* gnu/packages/tex.scm (texlive-cs): Remove SIMPLE-TEXLIVE-PACKAGE
call.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm42
1 files changed, 19 insertions, 23 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fb1165106b..453f871969 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4785,29 +4785,25 @@ polyglossia package rather than Babel.")
 
 (define-public texlive-cs
   (package
-    (inherit (simple-texlive-package
-              "texlive-cs"
-              (list
-               "fonts/enc/dvips/cs/"
-               "fonts/map/dvips/cs/"
-               "fonts/source/public/cs/"
-               ;; TODO: Remove these pre-built files after the manual
-               ;; build below is fixed.
-               ;; The font fails to build from the Metafont sources, with
-               ;; errors such as:
-               ;; This is METAFONT, Version 2.71828182 (TeX Live 2021/GNU Guix) [...]
-               ;; (./csaccent.mf
-               ;; >> cap_curve#-dot_size#
-               ;; ! Unknown relation will be considered false.
-               ;; <to be read again>
-               "fonts/tfm/cs/cs-a35/"
-               "fonts/tfm/cs/cs-charter/"
-               "fonts/tfm/public/cs/"
-               "fonts/type1/public/cs/"
-               "fonts/vf/cs/cs-a35/")
-              (base32 "1ww5lrqja051fh0ygmfdyy5a6bhwq9k5zv857vwiqf5syvw5djps")
-              #:trivial? #t))
-    (home-page "https://petr.olsak.net/cstex/")
+    (name "texlive-cs")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             ;; FIXME: Cannot build font metrics: "cannot find cmb12".
+             (list "fonts/enc/dvips/cs/"
+                   "fonts/map/dvips/cs/"
+                   "fonts/source/public/cs/"
+                   "fonts/tfm/cs/cs-a35/"
+                   "fonts/tfm/cs/cs-charter/"
+                   "fonts/tfm/public/cs/"
+                   "fonts/type1/public/cs/"
+                   "fonts/vf/cs/cs-a35/"
+                   "fonts/vf/cs/cs-charter/")
+             (base32
+              "0nzzcg1yvbslhqm5lsfcpqh6sbzkmnmmgyakg9l8855qpa8g9bf3")))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-cmexb))
+    (home-page "https://ctan.org/pkg/csfonts")
     (synopsis "Czech/Slovak-tuned Computer Modern fonts")
     (description "This package provides Czech/Slovak-tuned Computer Modern
 fonts in the Metafont format; Type 1 format versions (csfonts-t1) are also