summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-20 19:14:31 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-20 19:14:31 +0100
commit2ec30608b2b9ffc0ca4d33c231052e0d73899837 (patch)
treecada899abd73c75c12d28150358f511137b5d094 /gnu
parent166ccaefe8f3682ac1c7739b7f7ee6640c2e369b (diff)
downloadguix-2ec30608b2b9ffc0ca4d33c231052e0d73899837.tar.gz
gnu: Add solarus-quest-editor.
* gnu/packages/games.scm (solarus-quest-editor): New variable.
(solarus): Add a comment about linked updates.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 01580f75ff..ee1571e624 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2240,6 +2240,8 @@ and defeat them with your bubbles!")
 (define-public solarus
   (package
     (name "solarus")
+    ;; XXX: When updating this package, please also update hash in
+    ;; `solarus-quest-editor' below.
     (version "1.6.4")
     (source
      (origin
@@ -2295,6 +2297,40 @@ in mind.")
     ;; CC-BY-SA 4.0.
     (license (list license:gpl3 license:cc-by-sa3.0 license:cc-by-sa4.0))))
 
+(define-public solarus-quest-editor
+  (package
+    (inherit solarus)
+    (name "solarus-quest-editor")
+    (version (package-version solarus))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/solarus-games/solarus-quest-editor")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1qbc2j9kalk7xqk9j27s7wnm5zawiyjs47xqkqphw683idmzmjzn"))))
+    (arguments
+     `(#:tests? #false                  ;no test
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-qt-build
+           ;; XXX: Fix build with Qt 5.15.  It has been applied upstream as
+           ;; 81d5c7f1 and can be removed at next upgrade.
+           (lambda _
+             (substitute* "src/entities/jumper.cpp"
+               (("#include <QPainter>" all)
+                (string-append all "\n" "#include <QPainterPath>\n")))
+             #t)))))
+    (inputs
+     `(("solarus" ,solarus)
+       ,@(package-inputs solarus)))
+    (synopsis "Create and modify quests for the Solarus engine")
+    (description
+     "Solarus Quest Editor is a graphical user interface to create and
+modify quests for the Solarus engine.")))
+
 (define-public superstarfighter
   (package
     (name "superstarfighter")