summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-24 17:11:30 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-24 17:11:30 +0200
commit3e6add96c52fc6c92acc9bb5da3eb5a208c90a67 (patch)
treea60e58b5a4a61162f58dadbf44fdea761f57b8d3 /gnu
parent23212bf9e68d53c18343149eeea9c436ab6f4f52 (diff)
downloadguix-3e6add96c52fc6c92acc9bb5da3eb5a208c90a67.tar.gz
gnu: gnome-mime-data: Do not use the bundled intltool.
* gnu/packages/gnome.scm (gnome-mime-data)[arguments]: New field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8a9ddf62c7..b560fe816a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1288,6 +1288,17 @@ is intended for user preferences; not arbitrary data storage.")
     (native-inputs
      `(("perl" ,perl)
        ("intltool" ,intltool)))
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (add-after 'configure 'use-our-intltool
+                    (lambda _
+                      ;; Do not use the bundled intltool commands, which lack
+                      ;; the "dotless @INC" fixes of our 'intltool' package.
+                      (substitute* (find-files "." "^Makefile$")
+                        (("^INTLTOOL_(EXTRACT|UPDATE|MERGE) = .*$" _ tool)
+                         (string-append "INTLTOOL_" tool " = intltool-"
+                                        (string-downcase tool) "\n")))
+                      #t)))))
     (home-page "http://www.gnome.org")
     (synopsis "Base MIME and Application database for GNOME")
     (description  "GNOME Mime Data is a module which contains the base MIME